Problemas de Pegado con PTGui (Ayuda por favor)

postproceso

(Esdras Velasco Hernandez) #1

Que tal buenos dias a todos.
La verdad yo habia empezado a trabajar las fotografias 360 con una Gear 360, y para la virtualizacion utilizaba roundme.
Luego de eso con muchos consejos de parte de Mario Carvajal y Miguel Arenas, aprendi a realizar fotografias 360 areas, y les agradesco infinitamente por eso. Para las 360 Areas use autopano para unirlas y me quedaban excelentes y me tocaba retocarlo un poquito con Photoshop.

Yo estaba conciente de que mis fotografias 360 era de muy baja calidad y los clientes se merecen lo mejor. Por eso mismo adquirí el siguiente equipo:

Rotula Nodal Ninja 3
Rokinon 8mm
Nikon d5300

El problema que tengo es que ptgui no me pega bien la fotografias, me podrian ayudar para ver donde esta mi error. No eh comprado PTGui y estoy usando la version de pruebas, no se si es por eso que no me compila bien, o es que estoy usando mal la rotula.

Estas son las fotografia de mi sala, Tome 10 fotos en total, ya que no es full frame mi camara, tome 6 cada 60 grados, luego una de zenit, 2 de nadir, y 1 de sin tripode. Intento hacer que la linea roja de la camara quede en medio de donde gira el simbolo de la ruedita.
Aqui estan unas fotos de como lo pongo:
https://www.dropbox.com/sh/qvwbbdvxd7pykrv/AAAa4R24C6f3aAcsl9acT9GIa?dl=0

Estas son las fotografias que saque:
https://www.dropbox.com/sh/re9hobgctbfamvm/AAC8DEtuX-i29eZlHOjt2rxZa?dl=0

Luego realizo los siguientes pasos:
https://www.dropbox.com/sh/nmriehxyxc1yzpx/AAAeWZQWW6l9gtgoYR3oR2aka?dl=0

lo de mascaras si me sale perfecto pero según vi en un video de Mario eso hasta despues de optimizar, el problema que miro es que tiene alto el numero de distancias de puntos de control, y por lo mismo dice que esta mal (bad).

En resumen:
Que estoy haciendo mal?
O Es el ptgui trial que hace mal el trabajo?

Muchas gracias!
Saludos


(Andres Felipe Alzate G) #2

@esdras111 Hola amigo, en estos momentos no puedo descargar las fotos y ver como me va en el pegado, pero por lo que escribiste " Intento hacer que la linea roja de la camara quede en medio de donde gira el simbolo de la ruedita." y las fotos que enviaste de la camara (yo tambien tengo una d5300 y rokinon 8mm) veo donde esta el primer error. efectivamente no tienes bien ajustado el punto nodal, por lo q comentas estas basandote en la linea roja del lente… y veo que tienes la camara muy muy hacia adelante. el punto nodal de ese lente esta aproximadamente en la franja donde colocas el parasol. aca puede ver uno de los temas donde hay un video que te puede servir y seguro se solucionara tu problema.

punto nodal

saludos.


(Mario Carvajal) #3

Hola @esdras111

Tienes un primer problema que te lo dijo @FelipeAlzate, y que yo te lo grafico a continuación:

Yo soy usuario del Rokinon 8 mm y el Punto de No Paralaje lo he calculado cerca del borde, aproximadamente por donde te señalo con la flecha roja.

Por otra parte, tienes el lente por fuera del centro, eso es notorio en la toma que haces hacia abajo:

Debes llevar el centro del logo de Nodal Ninja hacia el centro del fotograma.

Esta mala posición de la cámara, sumado a que tienes una escena con elementos muy cercanos, hace que el resultado sea malo en PTGui:

Verás entonces una serie de errores de costura por muchas zonas:

Y por último, si usas la versión TRIAL de PTGui bajada de la página oficial de ellos, no hay lío. Pero si tienes alguna versión crackeada de las que se encuentran por ahí, tendrás un PTGui corrupto, eso lo he comprobado y lo tengo clarísimo, por eso a todos los colegas les digo que no vayan a usar esta versión crackeada, pero estoy seguro que en tu caso, lo que pasa es simplemente que no has hecho la labor de ajustar la rótula, así que la solución la tienes fácil.

Ya nos contarás…


(Esdras Velasco Hernandez) #4

Muchisimas gracias @FelipeAlzate , tenes toda la razon, tenia mal el punto nodal, ya me habia afligido que no me salía jajaja muchas gracias.

Este fue el resultado:
https://www.dropbox.com/s/5zqhwzwnb69dwy5/DSC_0096%20Panorama.jpg?dl=0

No la retoque en lightroom por que queria practicar esto primero. Ya con esto ya tengo para divertirme esta semana hasta pulir bien las fotografias.

Muchas Gracias!


(Esdras Velasco Hernandez) #5

Mario Muchisimas gracias, tenes toda la razon, y gracias por graficamelo me ayudo bastante.
Y si me daba cuenta que tenia muchos errores en costura, ya hasta estaba pensado en photoshopearlo pero eso me llevaria una eternidad jajaja
Si fijate que estoy usando la version trial, estoy que compro el programa ya jajaja
Aqui esta el resultado:
https://www.dropbox.com/s/5zqhwzwnb69dwy5/DSC_0096%20Panorama.jpg?dl=0

Tiene todavia errores pero ya son minimos y claro el de la sobra de mi brazo y el de la camara, pero estos ya los compondría usando un control inalambrico y claro tomando la foto sin tripode desde otra posicion, y practicando todavia mas con mascaras.
Pero como siempre te digo @Mario-Carvajal Muchisimas gracias!!!
Saludos desde Guatemala, y ya sabes que cuando vengas para aca tenes las puertas de mi casa abiertas brother.


(Michael Romano) #6

Buenos días, estoy empezando en esto del 360 y la verdad que estoy muy perdido. Tengo enormes problemas con el pegado de las imágenes y no se porque puede ser, si por fallos de la toma o la forma en que tengo configurado PTGui. Si me podeis ayudar estare muy agradecido.


(Michael Romano) #7

Yo subo todas las fotografías en tiff editadas ya en lighroom, todas en vertical, y cuando pulso align images, se me giran algunas y no me encuentra puntos de control, he puesto a mano puntos de control en todas las imágenes, la 0-1, 1-2, 2-3 y así sucesivamente, pero nada de nada. Las fotos están tomadas con nikon d750 - sigma 12-24 a 12mm y rótula panomaxx3.
Por favor me puedes ayudar y decirme por donde empezar para aprender a trabajar con ptgui, algun tutorial de configuración de ptgui y flujo de trabajo, desde la toma hasta obtener la panorámica?


(Pili) #8

Hola @Vagaworld el primer paso es revisar que tu equipo se encuentre bien configurado, es decir, que tu cámara con el lente que usas este justo en el punto de no paralaje según la rotula que tienes.
Adicional, sería bueno si organizas en lightroom las tomas, es decir todas en el mismo sentido.

Te adjunto nuevamente un video donde se explica como obtener el punto de no paralaje:
https://www.youtube.com/watch?time_continue=2&v=1jAhwFLimM0


(Michael Romano) #9

Ok lo comprobaré todo nuevamente, lo curioso es que antes de tener la rótula hice un par de panorámicas sin trípode y autopano me las pego sin problemas, pero con ptgui no he podido, y me gustaria aprender a hacerlo, porque tengo entendido que es el mejor software.


(Pili) #10

Lo es! Pero primero calibra la cámara! Ya el resto lo aprenderás poco a poco por estos lares :slight_smile:


(Michael Romano) #11

Muchas gracias @mapi, muy amable.
He de hacer alguna configuración en ptgui para que lea los archivos exif de las fotos? Eso espero, poco a poco aprender a trabajar con ptgui. Voy viendo los Tutoriales de @Mario-Carvajal pero aunque intento seguirlo en su flujo de trabajo nada me sale igual. Conocéis donde puedo hacer algún curso de 360 y ptgui? estoy en España.
Gracias por tu tiempo


(Pili) #12

Pues te cuento que justo Mario ha sacado un curso de ptgui, una comparación entre el ptgui tradicional (que es el que debes tener) y la versión que salió de prueba pero si no estoy mal ya no esta disponible para descarga.
Por que no me pasas un juego de fotos y miramos que esta pasando con tus tomas?
mi mail es pilar@pilarlinares.com


(Michael Romano) #13

Como puedo pasarte un grupo de imágenes? Hoy he tomado nuevas fotos con la cámara configurada correctamente en el punto nodal tal y como explica en el vídeo, mi trípode es estable (benro) con una rotula de bola de la misma marca, nivelo la rotula y coloco un rotor marca benro que queda nivelado, pero cuando giro no mantiene el nivel en todas as posiciones, y supongo que esto influye negativamente en el pegado. Si me dices donde puedo enviarte las fotos, yo te las hago llegar para que puedas probarlo tu misma.
muchas gracias por tu tiempo y tu ayuda.


(Pili) #14

te presento wetransfer https://wetransfer.com/
:slight_smile:


(Michael Romano) #15

:grinning:
conocía wetransfer, pero no tengo tu email para enviarte el wetransfer. si me lo pasas te envió las fotos :airplane:


(Pili) #16

te lo escribi dos comentarios más arriba :slight_smile:


(Juan Ignacio Llana) #17

Hola @Vagaworld
El tema del nivel no debería influir en el pegado tal y como lo explica Mario en el siguiente video.


Saludos


(Michael Romano) #18

Perdon, tengo tantos frentes abiertos que no llego a todo. Te lo paso hoy mismo.


(Michael Romano) #19

Muchas gracias por tu respuesta y por el vídeo, seguro me sera de gran ayuda.


(Esdras Velasco Hernandez) #20

@Vagaworld Mira amigo, disculpa que no había podido responder pero hasta hoy tuve tiempo libre , yo también hacia las fotografías en Autopano, y ese programa te logra hacer las fotografías en 360 pero NO salen muy bien y no son completas. Por eso mismo me pase a PTGUI.

Mira el primer error que tenes es que el PTGUI lo crakeaste o usaste una supuesta licencia (como lo se? por que lo intente también jajaja :joy: por que no estaba seguro si lo iba a usar tanto). Entonces tienes 2 opciones, Primera o usas la versión de pruebas para practicar o Compras el Programa. Si te das cuenta al final le respondí a Mario que si pude lograr la fotografía en la versión de pruebas. Yo compre el programa por que si lo estoy :grinning: usando.

El segundo error y es común, es el punto de no paralaje, revisa el video que te mando la maravillosa @mapi y con eso lo lograras. :smiley:

Este es mi ultimo trabajo en 360 que todavía no eh terminado… Y todavía me falta un resto de aprender de estos grandes maestros de la fotografia 360… pero ahi voy aprendiendo… :wink:

Ah y segui este video para lograr hacer la 360 como se debe:

Saludos amigo espero haberte ayudado.